Opened 11 years ago

Closed 11 years ago

#3632 closed bug (worksforme)

Slider - if multiple sliders are created, values should be able to be changed for all of them

Reported by: eric258 Owned by:
Priority: minor Milestone: 1.7
Component: ui.slider Version: 1.6rc2
Keywords: slider change updating moveTo Cc:
Blocked by: Blocking:

Description

If I have two elements with class 'test', and I create a slider with $('.test').slider();, UI will create two sliders, and they will both work, except that they don't automatically update each other. When I try to manually update by targeting the change event and calling moveTo, I get recursion errors. There should be a way to manually update the value of all sliders that are created. Or, multiple sliders created with one $.slider call should be bound to each other and both sliders should move in tandem with one another.

Change History (1)

comment:1 Changed 11 years ago by Scott González

Milestone: TBD1.6
Resolution: worksforme
Status: newclosed

This is not the intended behavior of any UI plugins. Instantiating multiple sliders with one call does not bind them together in any way. If you want to keep multiple sliders in sync, you have to do it manually using the callbacks. If you need help with that, please post to the jquery-ui group.

Note: See TracTickets for help on using tickets.