Opened 11 years ago

Closed 11 years ago

#3644 closed bug (duplicate)

Dialog: exception in IE when using a dialog and .ui-dialog-content has default margin (auto)

Reported by: rdworth Owned by:
Priority: blocker Milestone: 1.7
Component: ui.dialog Version: 1.5.2
Keywords: dialog IE error Cc:
Blocked by: Blocking:

Description

When you don't include a theme for dialog which sets a margin to the ui-dialog-content element, like

.ui-dialog-content { margin: 0; }

you get an exception in IE6

Here's a full test page:

<!DOCTYPE html> <html lang="en"> <head>

<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js"></script> <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.5.2/jquery-ui.js"></script> <style type="text/css">

.ui-dialog-content { margin: auto; }

</style> <script type="text/javascript"> $(function() {

$("<div/>").dialog();

}); </script>

</head> <body></body> </html>

Change margin: auto to margin: 0 and the exception goes away.

Change History (3)

comment:1 Changed 11 years ago by Scott González

Resolution: fixed
Status: newclosed

This has already been fixed for 1.6.

comment:2 Changed 11 years ago by rdworth

Resolution: fixed
Status: closedreopened

This is a duplicate of ticket #3086

It was fixed in rev [444]

comment:3 Changed 11 years ago by rdworth

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.