Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#3664 closed bug (fixed)

Dialog init fails on disconnected DOM Element after .remove()

Reported by: rdworth Owned by: rdworth
Priority: blocker Milestone: 1.7
Component: ui.dialog Version: 1.6rc2
Keywords: Cc:
Blocked by: Blocking:

Description

The following works

$('<div></div>').dialog()

The following fails

$('<div></div>').appendTo('body').remove().dialog()

with an exception "this.parentNode is null"

Change History (2)

comment:1 Changed 7 years ago by scottgonzalez

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r1151.

comment:2 Changed 7 years ago by scottgonzalez

See related ticket in core's Trac for the cause of the problem.

Note: See TracTickets for help on using tickets.