Opened 12 years ago

Closed 12 years ago

#3834 closed bug (wontfix)

During update (callback) placeholder still exists

Reported by: Marc Diethelm Owned by:
Priority: critical Milestone: 1.7
Component: ui.sortable Version: 1.6rc4
Keywords: sortable, update, callback, placeholder Cc:
Blocked by: Blocking:

Description

When the update callback is called the placeholder still physically exists in the sortable and interferes with the natural order of the universe.

jQuery("#sortable").sortable({
    update: function()
    {
        jQuery(this).children().length // sortable items + placeholder

        jQuery(this).html() // sortable items + placeholder
    }
});

Attachments (1)

sortable.update-callback.placeholder-exists.html (1.6 KB) - added by Marc Diethelm 12 years ago.
Reduced testcase

Download all attachments as: .zip

Change History (2)

Changed 12 years ago by Marc Diethelm

Reduced testcase

comment:1 Changed 12 years ago by paul

Resolution: wontfix
Status: newclosed

This is not a bug - many people rely on the placeholder/helper still being available in the update and stop callbacks. You can easily filter out the plceholder out of the set using $(this).children().not('.ui-sortable-placeholder') or the class you specified.

Note: See TracTickets for help on using tickets.