Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#3908 closed bug (wontfix)

Sortables on li with list-style-image : Regression in 1.6RC5 (and SVN) from 1.6RC4: can't drop onto the list-style-image anymore

Reported by: beat Owned by:
Priority: minor Milestone:
Component: ui.sortable Version: 1.6rc5
Keywords: Cc: beat@…
Blocked by: Blocking:

Description

Following worked fine in 1.6RC4 and before, but doesn't work in 1.6RC5 anymore:

If you add list-style-image to a list:

  • you can still drag with the list-style-image as a handle, but the drop on another such list-style-image of another li entry doesn't work anymore.

To reproduce:

CSS:

ul#fieldValuesList { list-style-type: none; border: 1px solid #999; margin: 5px; padding: 5px; width:90%; } ul#fieldValuesList li { list-style-image: url(images/mini-icons/icon-18-sort_up_down.png); margin-left: 20px; margin-bottom: 4px; cursor: move; } ul#fieldValuesList li input { cursor: text; } .fieldValuesList-selected { background-color: #E6F7D4; }

HTML:

<ul id="fieldValuesList>

<li>text A</li> <li>text B</li> <li>text C</li>

</ul>

I suppose probably same is true for normal bullets, but didn't test.

Problem is that I made the image be an arrow to show were to move. Worked fine in RC4 and before, but not now anymore.

Change History (4)

comment:1 Changed 11 years ago by beat

Forgot to give JS:

JS:

$('#fieldValuesList').sortable( { items: 'li', containment: 'parent', animated: true, placeholder: 'fieldValuesList-selected' } );

comment:2 Changed 11 years ago by beat

Filed a separate bug #3909 for a different bug than this one, but both together made it broken for my case.

comment:3 Changed 11 years ago by paul

Resolution: wontfix
Status: newclosed

That's because the margins are not part of the drop calculations anymore. set the list-style-position to 'inside'

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.