Skip to main content

Search and Top Navigation

#3908 closed bug (wontfix)

Opened January 22, 2009 04:14PM UTC

Closed January 23, 2009 02:30PM UTC

Last modified October 11, 2012 09:15PM UTC

Sortables on li with list-style-image : Regression in 1.6RC5 (and SVN) from 1.6RC4: can't drop onto the list-style-image anymore

Reported by: beat Owned by:
Priority: minor Milestone:
Component: ui.sortable Version: 1.6rc5
Keywords: Cc:
Blocked by: Blocking:

Following worked fine in 1.6RC4 and before, but doesn't work in 1.6RC5 anymore:

If you add list-style-image to a list:

  • you can still drag with the list-style-image as a handle, but the drop on another such list-style-image of another li entry doesn't work anymore.

To reproduce:


ul#fieldValuesList { list-style-type: none; border: 1px solid #999; margin: 5px; padding: 5px; width:90%; }

ul#fieldValuesList li { list-style-image: url(images/mini-icons/icon-18-sort_up_down.png); margin-left: 20px; margin-bottom: 4px; cursor: move; }

ul#fieldValuesList li input { cursor: text; }

.fieldValuesList-selected { background-color: #E6F7D4; }


<ul id="fieldValuesList>

<li>text A</li>

<li>text B</li>

<li>text C</li>


I suppose probably same is true for normal bullets, but didn't test.

Problem is that I made the image be an arrow to show were to move. Worked fine in RC4 and before, but not now anymore.

Attachments (0)
Change History (4)

Changed January 22, 2009 04:20PM UTC by beat comment:1

Forgot to give JS:


$('#fieldValuesList').sortable( { items: 'li', containment: 'parent', animated: true, placeholder: 'fieldValuesList-selected' } );

Changed January 22, 2009 04:22PM UTC by beat comment:2

Filed a separate bug #3909 for a different bug than this one, but both together made it broken for my case.

Changed January 23, 2009 02:30PM UTC by paul comment:3

resolution: → wontfix
status: newclosed

That's because the margins are not part of the drop calculations anymore. set the list-style-position to 'inside'

Changed October 11, 2012 09:15PM UTC by scottgonzalez comment:4

milestone: TBD

Milestone TBD deleted