Opened 11 years ago

Closed 10 years ago

Last modified 7 years ago

#3937 closed bug (duplicate)

IE sometimes doesn´t calculate the end and start values in color-Animations

Reported by: trixta Owned by:
Priority: minor Milestone: 1.6
Component: ui.effects.core Version: 1.6rc5
Keywords: Cc:
Blocked by: Blocking:

Description

In some rare cases IE seems to don´t go through the initial fx.state (fx.state === 0) and therefore doesn´t compute the color-Styles.

This problem appeared with borderColor-Animations using the animateClass-method in IE7/Vista.

I didn´t find the reason for this and only added the following line to the step-method: ...

if(fx.state == 0
!isFinite(fx.start[0])

...

modified version of effects.core (bugfixes, enhancements and new features): http://www.protofunc.com/scripts/jquery/classanimation/

Change History (3)

comment:1 Changed 11 years ago by paul

Milestone: TBD1.next

comment:2 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4251.

comment:3 Changed 7 years ago by Scott González

Milestone: 1.next1.6
Note: See TracTickets for help on using tickets.