Opened 11 years ago

Closed 11 years ago

#4002 closed bug (duplicate)

ui.datepicker incorrectly positioned when form element offscreen

Reported by: mark_story Owned by:
Priority: minor Milestone: 1.7
Component: ui.datepicker Version: 1.6rc5
Keywords: datepicker, position Cc:
Blocked by: Blocking:

Description

I'm having an issue where datepicker boxes are incorrectly placed when the form element the datepicker is attached to is offscreen. I've included a simple HTML file which shows the issue, tested in ff3, and safari. The datepicker is placed too high on the page and not directly above/below the form. I've tracked the issue down to _checkOffset(), it looks like the viewHeight is not taking into account scrollOffset but you know the code better.

Attachments (1)

test.html (690 bytes) - added by mark_story 11 years ago.
Reduction of bug.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by mark_story

Attachment: test.html added

Reduction of bug.

comment:1 Changed 11 years ago by caphun

Resolution: duplicate
Status: newclosed

This is a duplicate of #3863

Note: See TracTickets for help on using tickets.