Opened 11 years ago

Closed 11 years ago

#4012 closed bug (fixed)

Minify js error

Reported by: mharpste Owned by:
Priority: blocker Milestone: 1.7
Component: [meta] ui.downloadbuilder Version: 1.5.3
Keywords: minify Cc:
Blocked by: Blocking:

Description

Hi, I downloaded the ui core and interactions js file and am currently getting a javascript error on the minified version of the js file (The uncompressed version doesn't throw an error).

The error shows up in FF2 and FF3 at least. I'll try and attach the two version of the files that were generated for me. I downloaded them about an hour ago (1:30pm EST Friday January 30th 2009)

Attachments (2)

jquery-ui-coreAndInteractions-1.5.3.js (101.9 KB) - added by mharpste 11 years ago.
Uncompressed jquery ui js
jquery-ui-coreAndInteractions-1.5.3.min.js (66.5 KB) - added by mharpste 11 years ago.
Minified jquery ui file

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by mharpste

Uncompressed jquery ui js

Changed 11 years ago by mharpste

Minified jquery ui file

comment:1 Changed 11 years ago by rdworth

Component: ui.core[meta] ui.downloadbuilder
Milestone: TBD1.6
Priority: minorblocker

comment:2 Changed 11 years ago by initjh

I can confirm this issue is still present. The problem is that semi-colons need to be inserted between the functions as you get minified code like this: })(jQuery)(function(C) { and })(jQuery)(function(A) { which should be })(jQuery);(function(A) {

comment:3 Changed 11 years ago by initjh

;(function($))(jQuery); A fix would be to go into each plug-in and add a semi-colon in front of every enclosure, such as in effects.bounce.

Or (and as a fallback) you can hack the build script to check for and add ; before minifying it. Something like $code_to_minify = preg_replace("/(?<!;)\(function\(\$/",";(function(\$", $code_to_minify);

comment:4 Changed 11 years ago by rdworth

Resolution: fixed
Status: newclosed

Thanks initjh. Fixed.

Note: See TracTickets for help on using tickets.