Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#4020 closed bug (fixed)

UI Dialog - IE7 - Dialog won't open if any rounded corners are present

Reported by: Nikola Owned by:
Priority: major Milestone:
Component: ui.dialog Version: 1.6rc6
Keywords: dialog, corner, corners, IE7 Cc:
Blocked by: Blocking:

Description

In experimenting with several corner rounding plugins I've found that UI Dialog breaks in IE7 when rounding any corner on the page. Here is a paste of this happening with the Bullet Proof Corners plugin http://labs.parkerfox.co.uk/cornerz/. The same thing also occurs in JRC http://jrc.meerbox.nl/?page_id=4 as well as jQuery Curvy Corners http://blue-anvil.com/jquerycurvycorners/test.html and a few others I believe...

http://paste.pocoo.org/show/102098/

Change History (9)

comment:1 Changed 11 years ago by Scott González

Resolution: invalid
Status: newclosed

This sounds like a problem with the other plugins. If you can find a problem that actual points to the UI dialog, feel free to re-open this ticket with more details.

comment:2 Changed 11 years ago by rdworth

Milestone: TBD1.next
Resolution: invalid
Status: closedreopened

Let's keep this open until we or someone else determines where the problem is. Here's a link to the Cornerz Discussion Group http://groups.google.com/group/cornerz/browse_thread/thread/95ed7ffaafd022b3

comment:3 Changed 11 years ago by Nikola

It seems this problem is directly related to VML insertion in MSIE. There is a jQuery Development ticket on this as well as it can occur with some jQuery fx. Also, MSIE has to be restarted in order to clear the issue.

jQuery Bug Tracker http://dev.jquery.com/ticket/3265

comment:4 Changed 11 years ago by robmonie

I've been able to reproduce this problem without any external (rounded corner) libraries and some basic VML. I think the ticket logged against jquery core (http://dev.jquery.com/ticket/3265) mentioned by Nikola covers off the root of the problem.

comment:5 Changed 11 years ago by mgl

I have a very similar problem. After messing around for a couple days, I think the I've found that this is being caused by IE's rejection of Sizzle.selectors.filters.visible - I think 'visible' is reserved...or something. I posted a workaround at that involves renaming this function at http://dev.jquery.com/ticket/3265. This seems to work for me. Can anyone else confirm this?

comment:6 Changed 11 years ago by mgl

This is definitely a bug with the use of Sizzle's visible selector in IE with VML present, and is not specifically the fault of the ui dialog widget. There is a selector on line 188 of ui.dialog.js that uses ':visible', which triggers the bug identified in the ticket I linked to above.

I think this one can probably be closed.

comment:8 Changed 11 years ago by Scott González

Milestone: 1.next
Resolution: fixed
Status: reopenedclosed

comment:10 Changed 9 years ago by awhig

I am using jquery 1.4.4 and jquery ui 1.8.7. I am experiencing this problem. As soon as I comment out the curvycorners.js file (version 2.0.4), my dialog box appears in IE 7. Comment it back in, dialog box ceases to function. I can not tell from the comments, which version this fix is suppose to be in.

Last edited 9 years ago by awhig (previous) (diff)
Note: See TracTickets for help on using tickets.