Opened 11 years ago

Closed 10 years ago

Last modified 8 years ago

#4025 closed bug (duplicate)

Modal Dialog: Not able to tab between buttons in Safari

Reported by: epascarello Owned by:
Priority: critical Milestone: 1.6
Component: ui.dialog Version: 1.6rc6
Keywords: Cc:
Blocked by: Blocking:

Description

In the modal-confirmation.html demo on MAC OSX10 with Firefox 3 or Safari 3, I am not able to tab between the Cancel, Delete All, and X buttons on the dialog window.

Tab moves to either the Address Bar and Shift tab moves to the last disabled field in the form.

Change History (9)

comment:1 Changed 11 years ago by epascarello

Looks like with the other dialog demos you are not able to tab to the X button either.

comment:2 Changed 11 years ago by Scott González

Milestone: TBD1.6
Priority: minorcritical

Confirmed in Safari 3, works fine for me in Firefox 3.

comment:3 Changed 11 years ago by rdworth

Priority: criticalblocker

comment:4 Changed 11 years ago by rdworth

This thread suggests this may go further than just buttons:

keypress on ui1.6rc6 http://groups.google.com/group/jquery-ui/browse_thread/thread/7c9a1bf01fb33484

comment:5 Changed 11 years ago by Scott González

Priority: blockercritical

That thread is unrelated (I also can't reproduce the behavior described in the thread). This problem seems to be that Safari doesn't fire a keypress event for tabs.

comment:6 Changed 11 years ago by rdworth

Summary: Modal Dialog: Not able to tab between buttonsModal Dialog: Not able to tab between buttons in Safari

comment:7 Changed 11 years ago by Scott González

Milestone: 1.61.next

bumping to 1.next to determine what the new set of rules should be to deal with Safari's handling of tab keypresses.

comment:8 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #3768.

comment:9 Changed 8 years ago by Scott González

Milestone: 1.next1.6
Note: See TracTickets for help on using tickets.