Opened 11 years ago

Closed 9 years ago

#4059 closed bug (wontfix)

Dialog can only be initialized after document is ready in IE

Reported by: RavenRA Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.5.3
Keywords: Cc:
Blocked by: Blocking:

Description

Internet Explorer: If you make certain div a dialog on a fly (not using $(document).ready() ) and dialog's div is enclosed in another div, browser stops displaying the page and shows 'Internet Explorer cannot display the webpage'. Code to replicate is displayed at the bottom. If this is accepted behaviour, documentation should stress this moment. This has did NOT happen in jQuery 1.2.6 + ui.base rev 5174 + ui.dialog rev 5185.

<html>
 <head>
  <script type="text/javascript" src="http://code.jquery.com/jquery-latest.js"></script>
  <script type="text/javascript" src="http://ui.jquery.com/testing/ui/ui.core.js"></script>
  <script type="text/javascript" src="http://ui.jquery.com/testing/ui/ui.dialog.js"></script>
 </head>
 <body>
  <div>
   <div id='coverDialog' title='zeTitel'>blah</div>
   <script>$('#coverDialog').dialog();</script>
  </div>
 </body>
</html>

Change History (4)

comment:1 Changed 11 years ago by rdworth

Milestone: TBD1.next

comment:2 Changed 10 years ago by Scott González

Milestone: 1.next1.8

comment:3 Changed 9 years ago by ehynds

This problem exists in IE <= 7 and is caused by this bug: http://support.microsoft.com/kb/927917

In short, you cannot append to document.body unless the script tag directly descends it. test case @ http://jsfiddle.net/xwUQR/

comment:4 Changed 9 years ago by Scott González

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.