Opened 11 years ago

Closed 10 years ago

#4063 closed bug (fixed)

slider: horizontal slider handle jumps up when you click on it IE6

Reported by: rdworth Owned by: rdworth
Priority: blocker Milestone: 1.7
Component: ui.slider Version: 1.6rc6
Keywords: Cc:
Blocked by: Blocking:

Description

In IE6 when you click on a horizontal slider handle, it jumps to the left. Click again, and it jumps again.

Expected behavior: one mousedown, the handle shouldn't move. See #3972 and #4062

Change History (3)

comment:1 Changed 11 years ago by paul

The reason for this is that we subtract 'marginLeft' from the offset on line 200, but in IE, it doesn't return a computed 'px' value but the original 'em' value. Anyone have an idea how to handle this?

comment:2 Changed 11 years ago by rdworth

Owner: set to rdworth
Priority: criticalblocker
Status: newassigned

comment:3 Changed 10 years ago by rdworth

Resolution: fixed
Status: assignedclosed

Fixed in r2151

Note: See TracTickets for help on using tickets.