Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#4064 closed enhancement (duplicate)

Add Time to Datepicker

Reported by: volomike Owned by:
Priority: minor Milestone:
Component: ui.datepicker Version: 1.6rc6
Keywords: time Cc:
Blocked by: Blocking:

Description

It's a pretty common need for people to have a calendar field that adds in a time (either 24 or 12 hour) and not just date. The Datepicker control only gives you a date. The current DateTimePicker control is not part of the core UI and is not themeable with Themeroller CSS. It also has CSS bugs so that I cannot show the select boxes for the time (FF3, Ubuntu 8.04).

I would like to see the jQuery UI Team consider adding a time selection (just 2 popdown listboxes, 3 if you have 12 hour time and want to show AM/PM). I've seen a kludge for this but it doesn't give one a popdown listbox for this -- you end up having to be smart enough to type it into the textbox field above the calendar control, and some users might not find that intuitive enough.

Change History (3)

comment:1 Changed 11 years ago by kbwood

Resolution: duplicate
Status: newclosed

Duplicate of #2000.

comment:2 in reply to:  1 Changed 10 years ago by trushal

Hi,

I am also looking for same if you got any details with this then please please send me URl of that jquery that i can use this with date and time with one datepicker

waiting for your replay Thanks Trushal

comment:3 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.