Opened 11 years ago

Closed 10 years ago

#4067 closed bug (duplicate)

Other events are blocked

Reported by: Agone Owned by:
Priority: major Milestone: 1.8
Component: ui.selectable Version: 1.6rc6
Keywords: event Cc:
Blocked by: Blocking:

Description

When I use selectable, I can't use other event feature of jquery. I use selectable with jQuery.live in same element. Ex :

With this example I can select or unselect all div in my div but I can't display "I've clicked span in my div !" !!!

Code :

<div id="mydiv">
   <div>toto</div>
   <span>click here!</span>
   <div>titi</div>
   <span>click here!</span>
   <div>tata</div>
   <span>click here!</span>
   <div>tutu</div>
   <span>click here!</span>
   <div>tyty</div>
</div>
<script type="text/javascript">
$("#mydiv span").live("click",function(){alert("I've clicked span in my div !");});
$("#mydiv").selectable({filter:"div"});
</script>

I need to use live with selectable. I try to use jQuery.click or mouseup but it's the same problem when selectable is used...

Change History (4)

comment:1 Changed 11 years ago by banana989

I also had this problem in FF 3.0.6 (but not IE). jQuery version 1.3.2.

comment:2 Changed 11 years ago by rdworth

Milestone: 1.71.8

comment:3 Changed 11 years ago by ajacksified

Related (same thing?): http://dev.jqueryui.com/ticket/4219

Also seen in FF 3.0.7.

comment:4 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Closing as duplicate of #4219 since the other ticket has more info.

Note: See TracTickets for help on using tickets.