Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#4078 closed bug (duplicate)

Unspected behaviour whin month/year menu, date range and view multiple months

Reported by: cocotapioca Owned by:
Priority: minor Milestone: 1.6
Component: ui.datepicker Version: 1.6rc6
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Jörn Zaefferer)

someInput.datepicker({
        buttonImage: imgPath,
        buttonImageOnly: true,
        showOn: 'button',
        minDate: 0,
        maxDate: '+11M', // so end range is in january of the next year
        clearAtTop: false,
        firstDay:1,
        dateFormat:'yy-m-d',
        numberOfMonths:2
}

With this setup and today month as reference date (02/09), when the user select 2010 from the year dropdown, the calendar displays december 2009 and january 2010, now try to select some other month using the month dropdown (the year dropdown is in 2009), the calendar remains in the same months (december and january). This is happening because of range comparation and that the calendar believes that it should be displaying a month in 2010(which is partially true).

Change History (3)

comment:1 Changed 11 years ago by Jörn Zaefferer

Description: modified (diff)
Milestone: TBD1.next

comment:2 Changed 11 years ago by kbwood

Resolution: duplicate
Status: newclosed

Duplicate of #3778. Fixed in r1673.

comment:3 Changed 7 years ago by Scott González

Milestone: 1.next1.6
Note: See TracTickets for help on using tickets.