Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#4127 closed bug (duplicate)

Problem with tabs in IE7, when set html with javascript

Reported by: ezyhenrik Owned by:
Priority: major Milestone:
Component: ui.tabs Version: 1.6rc6
Keywords: tabs ie7 href Cc: henrik@…
Blocked by: Blocking:

Description

If you want to use the tab widget from jQuery UI on html that you have loaded with javascript, there is a problem in Internet Explorer 7. It works fine in both FireFox and IE8.

The problem is that when you assign your html code to the div. Internet Explorer changes the code. For example it adds the whole url to in the hreft tag. <a href="#tablink"> becomes <a href="http://website.com/#tablink">.

What happeneds in this IE7-case is that it loads all content of the current page into the tab-content area.

You can find more info and live exemple here http://teamezy.blogspot.com/2009/02/problem-with-jquery-tabs-in-ie7-when.html

Change History (2)

comment:1 Changed 11 years ago by klaus.hartl

Resolution: duplicate
Status: newclosed

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.