Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4152 closed bug (worksforme)

Resizable grid shrinks one grid square every time you resize

Reported by: Nathaniel Owned by:
Priority: critical Milestone: 1.7
Component: ui.resizable Version: 1.6rc6
Keywords: Cc:
Blocked by: Blocking:

Description

In firefox 3, when a resizable object on a grid begins being resized, it shrinks one grid "square" (both in width and in height) every time you begin resizing. This is only a minor annoyance until you have an item that is only east-west resizable -- then the item is distorted and can not be resized back to its original position.

Change History (5)

comment:1 Changed 10 years ago by rdworth

Milestone: TBD1.6

comment:2 Changed 10 years ago by Nathaniel

Two notes:

First, I accidentally marked this as core instead of resizable. That was my bad, I'm sorry -- can somebody change that?

Second, I poked around and this looks like it is a problem caused by setting box-sizing to border-box on the resizable item. When the size and original size of the resizable are set, they use elem.width() and elem.height(); if those are changed to elem.outerWidth() and elem.outerHeight() then the bug does not occur. I didn't want to mark this as a patch, because the resizable already uses outerWidth() and outerHeight() if the 'helper' option is set, and explicitly uses width() and height() otherwise, so I'm pretty sure that using outerWidth and outerHeight indescriminantly would break something.

comment:3 Changed 10 years ago by Scott González

Component: ui.coreui.resizable

Sounds like the patch is probably valid.

comment:4 Changed 10 years ago by Scott González

Resolution: worksforme
Status: newclosed

I can't reproduce this behavior using 1.6rc6, latest SVN or the snap to grid demo on jqueryui.com. Feel free to re-open this ticket if you can attach, or link to, a test page showing the problem.

comment:5 Changed 10 years ago by Nathaniel

The probable cause of the discrepancy was that the resizables were using -moz-box-sizing: border-box, which I think may have messed with some things. I'll see if I can throw together a simple page showing the problem. Thanks.

Note: See TracTickets for help on using tickets.