Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#4176 closed bug (duplicate)

Problem when setting range

Reported by: tic2000 Owned by:
Priority: minor Milestone:
Component: ui.slider Version: 1.6rc6
Keywords: range Cc:
Blocked by: Blocking:

Description

I've noticed this problem in latest FF, IE7 and Safari 3.1.2. It can be checked on http://jqueryui.com/demos/slider/#colorpicker too. The problem is if you set

$("#slider").slider({range: 'min'});

or

$("#slider").slider({range: 'max'});

for a single slider, when the slider reaches 0 you can't move it with the mouse anymore, only from keyboard. After you move it just once from keyboard all turns back to normal. The problem seems to appears only if the minimum value is 0. If I set the slider like this:

$("#slider").slider({range: 'min', min: 1, max: 101});

everything works as it should.

Change History (3)

comment:1 Changed 11 years ago by rdworth

Resolution: duplicate
Status: newclosed

Duplicate of #4016 Fixed in r1953

comment:2 Changed 11 years ago by tic2000

Sorry, I didn't know the bug was already reported. I searched for range, not vertical, since the problem it's not the orientation of the slider, but if you use range or not.

comment:3 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.