Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#4191 closed bug (worksforme)

Sortables

Reported by: bryan Owned by:
Priority: major Milestone: 1.6
Component: ui.sortable Version: 1.6rc6
Keywords: Cc:
Blocked by: Blocking:

Description

Hopefully I can explain this correctly:

When using a sortable that's longer than the height of the browser window, scrolling down to drag a list item near the bottom up produces unexpected behavior. Instead of grabbing the item that the cursor is above, it grabs an item above it that's the same distance away as the distance scrolled. Meaning that the farther you scroll, the more pronounced the error becomes. It pretty much makes sorting anything near the bottom of the given list impossible.

I have attached some screenshots, hopefully they illustrate the problem effectively.

Attachments (3)

sortable-correct.png (223.3 KB) - added by bryan 10 years ago.
ui.sortable Correct Behavior
sortable-incorrect.png (248.3 KB) - added by bryan 10 years ago.
ui.sortable Incorrect Behavior
sortable_ticket_4191.html (1.1 KB) - added by rdworth 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by bryan

Attachment: sortable-correct.png added

ui.sortable Correct Behavior

Changed 10 years ago by bryan

Attachment: sortable-incorrect.png added

ui.sortable Incorrect Behavior

Changed 10 years ago by rdworth

Attachment: sortable_ticket_4191.html added

comment:1 Changed 10 years ago by rdworth

Resolution: worksforme
Status: newclosed

I was not able to reproduce this with a simple test page (see attached). If you can create a simple test page that demonstrates the issue, please reopen and attach. Thanks.

comment:2 Changed 10 years ago by bryan

It seems like the error is in the latest Webkit builds, as I watched my fiance do the same thing in the current version of Safari without any problems.

comment:3 Changed 7 years ago by Scott González

Milestone: 1.next1.6
Note: See TracTickets for help on using tickets.