Opened 11 years ago

Closed 10 years ago

#4221 closed bug (notabug)

Sortable Lists deactivate if empty

Reported by: tehmeph Owned by:
Priority: major Milestone: 1.8
Component: ui.sortable Version: 1.6rc6
Keywords: Cc:
Blocked by: Blocking:

Description

I've got two connected "sortables:" #left_drag_area and #right_drag_area.

If I drag all of the items out of either of them, the now-empty one seems to be deactivated and I can no longer drag anything into them.

Code is attached

Attachments (1)

separator.txt (1.4 KB) - added by tehmeph 11 years ago.
Example code

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by tehmeph

Attachment: separator.txt added

Example code

comment:1 Changed 11 years ago by tehmeph

Just to be certain, testing in Firefox 3.0 and 3.1-beta2

comment:2 Changed 11 years ago by Jörn Zaefferer

Milestone: TBD1.7

comment:3 Changed 11 years ago by rdworth

Milestone: 1.71.8

comment:4 Changed 10 years ago by paul

Resolution: invalid
Status: newclosed

This is not a bug. The problem you have is that the actual element the sortable() function is applied on needs to have a width and height, even if it is empty, in order to be able to accept items.

Note: See TracTickets for help on using tickets.