Opened 11 years ago

Closed 11 years ago

#4235 closed bug (fixed)

dialog('close') fails in IE in rev >= 2119

Reported by: aflynt Owned by:
Priority: major Milestone: 1.7
Component: ui.dialog Version:
Keywords: Cc:
Blocked by: Blocking:

Description

Revision 2119 of ui.dialog.js caused a regression bug where calls to the close method in IE when options.hide is not set don't actually remove the dialog from the screen.

The problem is that self.uiDialog.hide() is no longer called when options.hide isn't set and self._trigger('close', event); doesn't seem to close the dialog in IE.

I've attached a patch that fixes this.

Attachments (1)

ui.dialog.js.patch (643 bytes) - added by aflynt 11 years ago.
Patch for IE dialog close regression.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by aflynt

Attachment: ui.dialog.js.patch added

Patch for IE dialog close regression.

comment:1 Changed 11 years ago by Jörn Zaefferer

Milestone: TBD1.7

comment:2 Changed 11 years ago by rdworth

Milestone: 1.71.8

comment:3 Changed 11 years ago by Scott González

Milestone: 1.81.7
Resolution: fixed
Status: newclosed

Fixed in r2134.

Note: See TracTickets for help on using tickets.