Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#4259 closed bug (notabug)

DOM Elements conflicting

Reported by: jane1916 Owned by:
Priority: major Milestone:
Component: ui.tabs Version: 1.6rc6
Keywords: Cc:
Blocked by: Blocking:

Description

When two contents contain DOM elements with same name they conflict. The contents are loaded by AJAX and is difficult to change the DOM Element names. I have tried caching the contents of the 1st div while hiding but the problem is when the div is loaded again the javascript in that div re-initializes all the widgets again which is not required. Please let me know if there is a way to solve this problem

Change History (2)

comment:1 Changed 11 years ago by klaus.hartl

Resolution: invalid
Status: newclosed

Ids in a document have to be unique as per specification. I cannot offer a workaround for scripting on top of an invalid DOM.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.