Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4327 closed bug (duplicate)

Generated styles are repeated many many times

Reported by: robert.hoffmann Owned by:
Priority: blocker Milestone: 1.7.1
Component: [meta] ui.downloadbuilder Version: 1.7
Keywords: Cc:
Blocked by: Blocking:

Description

Juste about every single theme that can be downloaded via theme roller is way too big because apparently the output is looped multiple times.

The most obvious theme to see this in is "smoothness" where the generated css hits 742kb mark !

After manually removing redundancies from this theme, it went down to 26kb ..however juste about every single theme is impacted.

Reproduction: Go to jqueryUI build custom download page Deselect all components, aside the theme you want Open the css file & select a big chunk of code anywhere & do a find ..you'll find between 2 (start) & 35 (smoothness) times the same stuff just repeated over & over.

Also if you go to "modify theme" & make a minor adjustment & then download the "custom theme", there seems to be elements missing from the generated code.

For example i wanted to see if "smoothness" would be fixed if i made a minor adjustment, so i went to theme roller, selected smoothness, changed drop shadow thickness from 8px to 7px, selected download, and the final css went from 742Kb to 18Kb, however the theme was broken.

Change History (4)

comment:1 Changed 11 years ago by rdworth

Component: [meta] ui.themeroller[meta] ui.downloadbuilder

comment:2 Changed 11 years ago by rdworth

Milestone: TBD1.8

comment:3 Changed 11 years ago by rdworth

Resolution: duplicate
Status: newclosed

Duplicate of #4296

comment:4 Changed 11 years ago by rdworth

Milestone: 1.81.7.1
Note: See TracTickets for help on using tickets.