Opened 11 years ago

Closed 10 years ago

#4338 closed bug (duplicate)

DatePicker shown under Dialog box

Reported by: mattdeclaire Owned by:
Priority: minor Milestone: 1.8
Component: ui.datepicker Version: 1.7
Keywords: Cc:
Blocked by: Blocking:

Description

I loaded a form with AJAX into a Dialog box. Inside the form I had a text box, and applied datepicker() to it. Everything worked fine, but the z-index of the datepicker was lower than the dialog box, and therefore hidden.

Change History (6)

comment:1 Changed 11 years ago by kbwood

Resolution: wontfix
Status: newclosed

You need to adjust the z-index of the datepicker appropriately in the CSS for your site:

#ui-datepicker-div { z-index: ???; }

comment:2 Changed 11 years ago by ecaron

If the UI theme can't be updated to address this, could the documentation at least be improved to address this? It seems like many people have this issue.

comment:3 Changed 11 years ago by Jörn Zaefferer

Resolution: wontfix
Status: closedreopened

comment:4 Changed 11 years ago by Jörn Zaefferer

Milestone: TBD1.7.2

This needs either get fixed in code or properly documented.

comment:5 Changed 11 years ago by Jörn Zaefferer

Milestone: 1.7.21.8

comment:6 Changed 10 years ago by kbwood

Resolution: duplicate
Status: reopenedclosed

Duplicate of #4580.

Note: See TracTickets for help on using tickets.