Opened 11 years ago

Closed 10 years ago

#4371 closed bug (notabug)

Problem with removeClass in ui.tabs and IE8

Reported by: binside Owned by:
Priority: minor Milestone: 1.8
Component: ui.tabs Version: 1.7
Keywords: tabs, IE8 Cc:
Blocked by: Blocking:

Description

I am using my own style for ui.tabs The selected tab has 2 background images, because of the rounded corners and different width of each tab. When I click on another tab, the previous selected tab is not showing properly. Here is the CSS part:

li.ui-tabs-selected {
	display: block;
	float: left;
	height: 32px;
	background: #E6E6E6 url(tab-right.gif) no-repeat top right;
}

li.ui-tabs-selected a {
	color: #FF6600;
	background: transparent url(tab-left.gif) no-repeat top left;
}

It works fine in all major browsers like FF 3.0.7, Opera 9.62, Safari, Chome, IE7. The problem is with IE8 only. It happens both with JQuery UI 1.5.3 and 1.7 Seems like the js is removing the class only for li.ui-tabs-selected and not for li.ui-tabs-selected a

Attachments (1)

shot2.png (6.6 KB) - added by binside 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by binside

Attachment: shot2.png added

comment:1 Changed 11 years ago by Cloudream

It seems that this is a bug for IE8 but not tabs, could you submit your page source code here?

comment:2 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.7.2

comment:3 Changed 10 years ago by Jörn Zaefferer

Milestone: 1.7.21.8

comment:4 Changed 10 years ago by Scott González

Resolution: invalid
Status: newclosed

Closing due to invalid report (described behavior is impossible) and there has been no update in 8 months.

Note: See TracTickets for help on using tickets.