Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#4405 closed bug (notabug)

Clicking on Tab throws an exception in IE7 after receiving the response of an Ajax request

Reported by: numericalexample.com Owned by:
Priority: minor Milestone:
Component: ui.tabs Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery UI tabs work fine in IE7 except for one particular case.

When clicking on a tab after having received the response on an Ajax request, IE7 throws an exception.

Follow these steps to reproduce the exception:

  1. Set up some tabs in javascript
  2. do an ajax request which needn't be related to the tabs
  3. the ajax request completes without errors
  4. click on a tab

Or:

  1. Open page http://www.numericalexample.com/content/view/76/33/
  2. Click on "Compute" (does the ajax request)
  3. Ajax request completes: Total computed Vitamin B12 (μg/day): 0.0000
  4. Click on Tab "Instructions"

In the second four steps the test is with jQuery 1.2.6 and jQuery ui 1.6 but I can assure you the same bug is still present with jQuery 1.3.2 and jQuery UI 1.7.1.

Others have reported a similar unsolved bug in Google Groups, with less details.

Change History (4)

comment:1 Changed 11 years ago by numericalexample.com

This bug can be closed again. I got rid of the problem by cleaning up some code. Sorry for the confusion.

comment:2 Changed 11 years ago by numericalexample.com

Please neglect my previous comment.

The problem was that I tried to write an empty string in the jQuery html method: $('#receivingId').html(varContainingEmptyString); This happened in the response method of an Ajax call.

FireFox handled this OK but in IE7 the clicking on tabs appeared to be broken from that moment.

comment:3 Changed 11 years ago by klaus.hartl

Resolution: invalid
Status: newclosed

comment:4 Changed 8 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.