Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#4409 closed bug (duplicate)

Massive memory leak with dialog in IE7 (6 not tested)

Reported by: VinZ40K Owned by:
Priority: major Milestone:
Component: ui.dialog Version: 1.7.1
Keywords: Memory IE7 leak Cc:
Blocked by: Blocking:

Description

Opening a modal dialog with IE7 causes an increase of about 20 mb in used memory for IE7. If you keep opening and closing the dialog the amount stacks up rapidly, and even navigating away to another page doesn't free up all the memory (only about 40%). The demopage of the dialog (http://jqueryui.com/demos/dialog/#modal-message) shows this too, try clicking the modal dialog a few times in a row and check mem usage.

We use the dialog in an ajax application with many popups, and an avarage user can crash IE with an out of memory error in no time. (If you open 20 popups in a row your mem usage is up 400mb)

Some observations:

  • Apparently this is somehow related to the modal functionality, since the non modal dialog doesn't have this problem.
  • Destroying a dialog doesn't free any memory, not even after

refreshing the page. Closing the dialog (or just refresh with dialog open) does free up the memory. It seems destroying the dialog causes this somehow.

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4188.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.