Opened 11 years ago

Closed 10 years ago

#4423 closed bug (wontfix)

datepicker not displayed on first click with <body dir="rtl">

Reported by: ovesh Owned by:
Priority: minor Milestone: 1.8
Component: ui.datepicker Version: 1.7.1
Keywords: rtl Cc:
Blocked by: Blocking:

Description

On a page where the dir attribute is set to "rtl" on the body tag, i.e. <body dir="rtl"> then the datepicker is not displayed until the 4th click.

This can be worked around by setting dir="rtl" on a div nested in the body.

Change History (2)

comment:1 Changed 11 years ago by Scott González

Milestone: TBD1.8

comment:2 Changed 10 years ago by kbwood

Resolution: wontfix
Status: newclosed

I can only reproduce this in IE7 and even then it appears on the second click. The problem is the ui-helper-hidden-accessible class initially applied to the popup datepicker division. This positions it very far to the left, which effectively increases the page width and causes the location of the input field to be read as very far to the right. The datepicker is then shown at that position, i.e. off the screen. Thereafter the positioning undoes the initial setting and the datepicker shows normally. This needs to be fixed in the ThemeRoller core CSS. Raised as a CSS problem: #4623.

Note: See TracTickets for help on using tickets.