Opened 10 years ago

Closed 7 years ago

#4477 closed bug (invalid)

Sorting works improperly

Reported by: mg Owned by: mg
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.7.1
Keywords: Cc: mg@…
Blocked by: Blocking:

Description

Sorting on many columns with elements of different size behaves incorrectly. For example it's impossible to put an element at the bottom when column's padding-bottom is lower than element's height. See attached images/demo.

Attachments (2)

step1.jpg (186.9 KB) - added by mg 10 years ago.
step2.jpg (180.5 KB) - added by mg 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by mg

Attachment: step1.jpg added

Changed 10 years ago by mg

Attachment: step2.jpg added

comment:2 Changed 10 years ago by Jörn Zaefferer

Milestone: 1.7.21.8

comment:3 Changed 10 years ago by Jörn Zaefferer

Priority: blockerminor

Reproducable on Firefox 3.0.xx/Win, but really a minor issue. It works fine when you move it above first, then below.

comment:4 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:5 Changed 7 years ago by petersendidit

Owner: set to mg
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket. The linked demo now returns a 404.

Additionally, be sure to test against the git version of both jQuery UI and jQuery to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/ZgAqH/Open the link and click to "Fork" (in the top menu) to get started.

comment:6 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.