Opened 11 years ago

Closed 11 years ago

#4495 closed bug (duplicate)

Value not being returned

Reported by: ababkov Owned by:
Priority: minor Milestone: 1.8
Component: ui.progressbar Version: 1.7.1
Keywords: progress bar, value Cc:
Blocked by: Blocking:

Description

$(".selector").progressbar('value');

Expected Behavior: Returns current progress bar value (integer)

Actual Behavior: Returns base progress bar element object.

aria-valuenow attribute (set via the setter method) is holding an integer value of 20 at the time of the call. Value can be retrieved via an attr call on the element: .attr("aria-valuenow") and returns the expected integer value at time of this call.

Change History (3)

comment:1 Changed 11 years ago by Jörn Zaefferer

Milestone: TBD1.7.2

comment:2 Changed 11 years ago by Jörn Zaefferer

Milestone: 1.7.21.8

comment:3 Changed 11 years ago by rdworth

Resolution: duplicate
Status: newclosed

Duplicate of #4427

Note: See TracTickets for help on using tickets.