Opened 11 years ago

Closed 7 years ago

#4508 closed bug (invalid)

Sortable grid vertical cursor position issues

Reported by: RowanBeentje Owned by: RowanBeentje
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.7.1
Keywords: sortable grid Cc:
Blocked by: Blocking:

Description

The Sortable plugin, when in Grid mode, interacts oddly depending on the vertical position of the mouse cursor within the dragged item. Steps to reproduce:

1) Visit http://jqueryui.com/demos/sortable/#display-grid
2) Click on item "3", in the space between the top of the digit "3" and the top border.
3) Drag it horizontally across "4" - note that four never shifts across, unless you also drag "3" downwards.
4) Reload the page.
5) Click on the very bottom of item "4".
6) Drag it horizontally to the left, above "3" - note that it also needs to be moved upwards for the sort to occur.

I'm actually working with a non-grid sortable widget which uses float on the sortable items, to achieve a grid-like feel with mixed-height items. Most of the items that require sorting are significantly taller than they are wide, so this issue is being run into all the time - still easy once you have the knack of dragging to the top/bottom as well, but it can mean sorts will *never* register if also used with the Constrain option - if you've clicked too near the top or bottom!

I'm aware that this is "unsupported" behaviour, but I figure that if the Grid view behaviour is fixed, it's likely to resolve the issues for me as well :)

Keep up the great work!

Change History (5)

comment:1 Changed 11 years ago by Jörn Zaefferer

Milestone: TBD1.7.2

comment:2 Changed 11 years ago by Jörn Zaefferer

Milestone: 1.7.21.8

comment:3 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:4 Changed 7 years ago by mikesherov

Owner: set to RowanBeentje
Status: newpending

Thanks for contributing! I'm not sure what the problem is from the description of the repro steps provided. What were you expecting to happen vs. what actually happened? Thanks again!

comment:5 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.