Opened 11 years ago

Closed 11 years ago

#4511 closed bug (duplicate)

ESCAPE key close ALL opened modal dialogs

Reported by: xpg934 Owned by:
Priority: critical Milestone: 1.8
Component: ui.dialog Version: 1.7.1
Keywords: dialog escape modal Cc:
Blocked by: Blocking:

Description

When I open two modal dialogs and press ESCAPE - all dialogs are closed. Not only topmost.

Attachments (1)

esc-bug.html (1.5 KB) - added by xpg934 11 years ago.
Example

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by xpg934

Attachment: esc-bug.html added

Example

comment:1 Changed 11 years ago by Jörn Zaefferer

Milestone: 1.7.21.8

comment:2 Changed 11 years ago by Jörn Zaefferer

The dialog itself binds keydown event to itself for closing the dialog on ESC; in addition, the dialog overlay binds a keydown event to document, without filtering to close only the active dialog.

There doesn't seem be a trivial way to detect multiple modal dialogs. Maybe the right approach here is to prevent multiple modal dialogs in the first place. If we allow two, we allow an unlimited amount, sure to be causing performance issues, as each creates its own overlay.

comment:3 Changed 11 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #3539.

Note: See TracTickets for help on using tickets.