Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#4563 closed bug (worksforme)

Dialog won't reopen if hide effect used on close?

Reported by: Stretch2m Owned by:
Priority: minor Milestone: 1.8
Component: ui.dialog Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

It appears that using a hide effect on a dialog causes problems with reopening the dialog after having been closed.

My code:

$(function() {

$("#profiledialog").dialog({

title: "Employee Profile",

width: 608, modal: true, resizable: false, hide: "puff", autoOpen: false

});

});

function openProfile() {

$("#profiledialog").dialog("open");

}

I call openProfile when I want to display the dialog. When I close the dialog, it closes with the "puff" effect correctly.

However, with the code as shown, when I subsequently call openProfile to open the profile again, the screen dims (as it should with a modal dialog) but the dialog itself does not reappear.

If I remove the "hide: 'puff'" option, when I close the dialog and call openProfile(), the dialog reappears as expected.

Could it be that the "puff" effect leaves the dialog in an invisible state? If so, how would I restore the dialog to its original state following the puff effect?

Change History (3)

comment:1 Changed 10 years ago by Jörn Zaefferer

Component: ui.coreui.dialog
Milestone: TBD1.8

comment:2 Changed 10 years ago by Scott González

Resolution: worksforme
Status: newclosed

I can't reproduce this.

comment:3 Changed 9 years ago by cowboyonrails

This is a real bug, I hit the same thing. I am SO happy Stretch2m narrowed it down to the hide 'puff' functionality, I took that out, and it started working right away... I am using Firefox 3.5 (should not matter...) I will make a test case to post up here, then I will reopen the ticket.

Note: See TracTickets for help on using tickets.