Opened 10 years ago

Closed 6 years ago

#4571 closed bug (worksforme)

Webkit Draggable/Droppable

Reported by: breaker05 Owned by:
Priority: major Milestone: 2.0.0
Component: ui.droppable Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

When a draggable element is dropped on a droppable element, the 'over' event is fired successfully, however the 'drop' event is never called. I am developing in adobe air and found this bug, but when I tested my page in Firefox 3.0 it works great. I wanted to verify it was a webkit related issue, so I tested in safari 4 and the 'drop' event is never fired either.

Change History (9)

comment:1 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8

comment:2 Changed 10 years ago by paul

Could you provide a reduced test case that we can check out?

comment:3 Changed 9 years ago by woodpile

I just filed "#5740: Drop/release fails on mobile platforms" and then found this. Pretty much dups. I will attach a test case to mine.

comment:4 Changed 9 years ago by Scott González

I cannot reproduce this bug on a desktop install of any webkit browser. Tested Safari 4, Safari 5, Chrome.

comment:5 Changed 9 years ago by woodpile

It has little to do with clicks and everything to do with touch events and how they're mapped back, so it's absolutely no surprise that you cannot reproduce on desktop versions. In fact, the bug I linked to specifically says, "Run that on mobile safari on a touch device and behavior is replicated." for the test case.

Are you working on this and related? I can help test. Please advise.

comment:6 in reply to:  5 Changed 9 years ago by Scott González

Replying to woodpile:

It has little to do with clicks and everything to do with touch events and how they're mapped back, so it's absolutely no surprise that you cannot reproduce on desktop versions. In fact, the bug I linked to specifically says, "Run that on mobile safari on a touch device and behavior is replicated." for the test case.

Are you working on this and related? I can help test. Please advise.

Yup, I'm aware that your ticket was specifically about touch events. However, this ticket specifically says that webkit browsers and air don't work. I wanted to clarify in a comment that the description is not correct. Also, I'm not sure that this ticket and your ticket are related. Does air use touch events for some reason? Can you run air apps on any mobile devices?

As for your ticket, we will be working on mobile support very soon. Any help would be greatly appreciated.

comment:7 Changed 9 years ago by woodpile

I thinking it has less to do with Air and more to do with the jQuery event model, since the described behavior is not really any diff than the behavior I described with touches. Are they related? I'd bet they are, perhaps not directly, but moreso than one might think.

comment:8 Changed 6 years ago by Scott González

Milestone: 1.9.02.0.0

comment:9 Changed 6 years ago by Scott González

Resolution: worksforme
Status: newclosed

I couldn't reproduce this 2 years ago and this definitely work in desktop WebKit browser today.

Note: See TracTickets for help on using tickets.