Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#4583 closed bug (notabug)

IE6 & IE7 crash as Jquery UI loads

Reported by: neuronix Owned by:
Priority: blocker Milestone:
Component: ui.core Version: 1.7.2
Keywords: IE6 IE7 crash page freeze Cc: cuby87@…
Blocked by: Blocking:

Description

IE just simply crashes as the UI loads on certain pages. The bug is not random but depends on the page loaded.

I'm not a browser specialist so i'm sorry to not be able to five any idea on the bug. I some how think that IE just cannot handle the UI intialization on complex pages (in my case 18Ko page of a browser game).. sort of overflow ?

The message (red cross modal error window) is : "Internet Explorer cannot open the Internet site : http://myurl.com Operation aborted."

Herewith a screenshot. I'm sorry the site is a bêta version so you won't be able to access it.

Attachments (1)

ie6_ie7_jquery_ui_crash.jpg (201.0 KB) - added by neuronix 10 years ago.
Screenshot of the error message

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by neuronix

Attachment: ie6_ie7_jquery_ui_crash.jpg added

Screenshot of the error message

comment:1 Changed 10 years ago by Jörn Zaefferer

Resolution: invalid
Status: newclosed

There is no way to "fix" this without a testpage.

comment:2 Changed 10 years ago by chesles

I'm getting the same error from IE 6 and 7; haven't tested in IE 8 yet.

the bug seems to happen for me only when I use a datepicker. It's hard to debug because of IE's caching and the way it handles the error. IE6 crashes completely; IE7 says "Internet Explorer cannot display the webpage". Then IE seems to have the cached page with the offending datepicker() call for a while, but eventually it reloads a version of the JS without any datepicker() and other than no datepicker, is just fine!

I will try to reproduce the problem on a test page and post a link as soon as I can.

comment:3 Changed 10 years ago by chesles

a bit of playing around showed that putting the call to datepicker() within $(document).ready like so:

$(document).ready(function () { $("#date").datepicker() });

makes IE not crash :)

it could be nice to update the docs/examples on using jqueryui to use the ready() event. my mistake was copy & pasting from the examples and while the thought crossed my mind that these calls should maybe be called on the ready() event, 1) they weren't in the examples, and 2) it works just fine in any browser other than IE, so i left them as-is. :P

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.