Opened 10 years ago

Closed 10 years ago

#4638 closed bug (duplicate)

Multiple color animations break in IE

Reported by: chrisbarr Owned by:
Priority: major Milestone: 1.8
Component: ui.effects.core Version: 1.7.2
Keywords: IE color Cc:
Blocked by: Blocking:

Description

When animating the color on multiple items at once (somewhat rapidly) IE throws a script error of "Error: Invalid property value." starting on line 248 of http://dev.jqueryui.com/browser/trunk/ui/effects.core.js

I've made a quick demo of it as seen here: http://jsbin.com/ecefa/edit

I've tested this and it breaks consistently in IE8, IE7 and IE6

Change History (3)

comment:1 Changed 10 years ago by Scott González

Component: effects.* (individual effect)effects.core
Milestone: TBD1.8

comment:2 Changed 10 years ago by mattbaker

Actually it's around line 265. I'm not sure where the "invalid property" is. I wrapped the following code in a try block and it seems to have alleviated the problem but it's a hack, not a fix. Obviously by try/catching the code some elements will fail to animate.

try{
fx.elem.style[attr] = 'rgb(' +
	Math.max(Math.min(parseInt((fx.pos * (fx.end[0] - fx.start[0])) + fx.start[0], 10), 255), 0) + ',' +
	Math.max(Math.min(parseInt((fx.pos * (fx.end[1] - fx.start[1])) + fx.start[1], 10), 255), 0) + ',' +
	Math.max(Math.min(parseInt((fx.pos * (fx.end[2] - fx.start[2])) + fx.start[2], 10), 255), 0) + ')';
}catch(e){}

comment:3 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4251.

Note: See TracTickets for help on using tickets.