Opened 10 years ago

Closed 10 years ago

#4644 closed bug (duplicate)

IE6 Memory Leak with just a datepicker

Reported by: mharen Owned by:
Priority: minor Milestone: 1.8
Component: ui.datepicker Version: 1.7.2
Keywords: memory leak Cc:
Blocked by: Blocking:

Description

I have a simple form which, when refreshed repeatedly, leaks lots of memory.

This occurs with a very recent jquery nightly and jquery-ui-1.7.2.

Please see my Stackoverflow question for more information, or load up the attached repro in IE6.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" >
<head>
  <link type="text/css" href="http://ajax.googleapis.com/ajax/libs/jqueryui/1.7.2/themes/smoothness/jquery-ui.css" rel="stylesheet" />
  <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js"></script>
  <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.7.2/jquery-ui.min.js"></script>

  <script type="text/javascript">
      $(document).ready(function() { $('.DatePicker:enabled').datepicker(); });
  </script>
</head>
<body>
  <form id='Form1' action='LeakTest3.htm'>
    <input class='DatePicker' /> 
    <input type='button' value='Refresh' onclick='window.location.reload();' />
  </form>
</body>
</html>

Attachments (2)

yikes.png (51.2 KB) - added by mharen 10 years ago.
LeakTest3.htm (827 bytes) - added by mharen 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by mharen

Attachment: yikes.png added

Changed 10 years ago by mharen

Attachment: LeakTest3.htm added

comment:1 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8

Most likely related to issues to be fixed in jQuery 1.3.3.

comment:2 Changed 10 years ago by Scott González

Component: ui.coreui.datepicker

comment:3 Changed 10 years ago by kbwood

Resolution: duplicate
Status: newclosed

Duplicate of #4566.

Note: See TracTickets for help on using tickets.