Skip to main content

Search and Top Navigation

#4648 closed bug (notabug)

Opened June 30, 2009 10:17PM UTC

Closed July 09, 2009 03:32PM UTC

Last modified January 17, 2010 06:08AM UTC

Download Builder fails often

Reported by: DarwinSurvivor Owned by:
Priority: major Milestone: 1.8
Component: [meta] ui.downloadbuilder Version: 1.7.2
Keywords: fail refresh Cc:
Blocked by: Blocking:

There are certain configurations that cause the Download Builder to fail. By fail, I mean the page pauses for 5 seconds (appearing to load), the refreshes with no download prompt.

To recreate, select:

UI Core - All

Interaction - All (except Selectable)

Widgets - All

Effects - None

(note this will work)

Now disable Interaction -> Droppable

(now it will NOT work)

I love the work you guys are doing and would hate for people to lose out because they simply can't download it properly :(

Attachments (0)
Change History (3)

Changed July 09, 2009 02:09PM UTC by jzaefferer comment:1

milestone: TBD1.8

Changed July 09, 2009 02:41PM UTC by d3r1v3d comment:2

I'm having a bit of trouble replicating this error. Here's the steps I'm using to test:

1. Browse to (

2. Uncheck selectable interaction.

3. Hit deselect all for effects.

4. Attempt to download distribution and verify that it works.

5. Uncheck droppable interaction.

6. Attempt to download again.

The first time I got to the last step, it paused for about three seconds and then allowed me to download a valid distribution. I think this combination hadn't been cached before and so it was attempting to build the distribution and cache it before allowing me to download it. Now, whenever I run this test procedure, it returns me the cached distribution immediately.

Not sure why the download builder would fail to cache this combination every time DarwinSurvivor tried to download it. It's possible that the user tried to cache under a peak load, although I'm not convinced it would fail repeatedly like it seemed to.

Was anyone else able to replicate this?

Changed July 09, 2009 03:32PM UTC by jzaefferer comment:3

resolution: → invalid
status: newclosed

Can't replicate it either. I tried a few other variations, until finding one that wasn't cached - took a few seconds, but worked fine otherwise.

Please reopen with a new description to reproduce.