Opened 10 years ago

Closed 10 years ago

#4661 closed bug (duplicate)

addClass, removeClass, toggleClass and switchClass don't work in Chrome

Reported by: rodboev Owned by:
Priority: critical Milestone: 1.8
Component: ui.effects.core Version: 1.7.2
Keywords: toggleClass switchClass Cc:
Blocked by: Blocking:

Description

Using the latest Google Chrome (2.0.172.33), the jQueryUI addClass, removeClass, toggleClass and switchClass overrides don't work. This is easy to reproduce as even the example pages don't work:

http://www.jqueryui.com/demos/addClass/

http://www.jqueryui.com/demos/removeClass/

http://www.jqueryui.com/demos/toggleClass/

http://www.jqueryui.com/demos/switchClass/

As a workaround, I'm using the animateToClass plugin instead.

Change History (4)

comment:1 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8

comment:2 Changed 10 years ago by Jörn Zaefferer

Component: ui.coreeffects.core

comment:3 Changed 10 years ago by rodboev

My mistake, this is a dupe of ticket #4324.

Charles Phillips also posted a great fix in that thread.

comment:4 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.