Opened 9 years ago

Closed 6 years ago

#4665 closed bug (wontfix)

jQuery UI 1.7.2 - Opera(9.63) issue with Form submitting through a dialog .

Reported by: vrn_shan Owned by:
Priority: major Milestone: 1.10.0
Component: ui.dialog Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

We are using jQuery 1.3.2 and jQuery UI 1.7.2 in our project.

Everything was working perfect till we were using jQuery UI 1.7.1. Then we upgraded to jQuery UI 1.7.2, but it is causing a trouble in Opera (9.63).

The issue is as follows :- There is a jQuery UI dialog with a textarea and a submit button which posts the data in "textarea" to the server. Before opening the dialog the value of textarea is set to blank. Also I am using Modal:true to get the overlay.

Now when I open the dialog for the 1st time, enter some data in textarea and click submit, it posts the data to server.Then I close the dialog, and reopen it, again enter some text in the text area and submit again. This time it is posting empty data (or whatever value was set for the "textarea" before openeing the dialog.)

The issue is only in Opera and rest browsers are working fine. Even opera works fine if i set modal as false, or if i use jQuery UI 1.7.1. I am attaching a sample program to demonstrate this issue.

Attachments (1)

sample_program.zip (52.0 KB) - added by vrn_shan 9 years ago.
Run the Html file using Opera

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by vrn_shan

Attachment: sample_program.zip added

Run the Html file using Opera

comment:1 Changed 9 years ago by Scott González

Component: ui.coreui.dialog
Milestone: TBD1.8

comment:2 Changed 9 years ago by cdael

This doesn't seem to be dependent on setting the value of the textarea. The second and subsequent openings of the dialog will retain the value from when the dialog was closed, whether this was done via the [X] button or a Cancel button that calls $(this).dialog('close'). The locked-in value will also be given to the server if the form is submitted.

Behavior observed in Opera-10.10 with jquery-1.3.2 and jquery-ui-1.7.2. As noted by the reporter, jquery-ui-1.7.1 from the Google CDN works fine.

comment:3 Changed 7 years ago by Scott González

This works properly in Opera 11.5x. Opera is super whacky with form fields in dialogs. See #7577 as well.

comment:4 Changed 6 years ago by Scott González

Milestone: 1.9.01.10.0

comment:5 Changed 6 years ago by petersendidit

Resolution: wontfix
Status: newclosed

This works in all the versions of Opera that we support.

Note: See TracTickets for help on using tickets.