Opened 10 years ago

Closed 9 years ago

#4674 closed bug (duplicate)

Overview documents for the Accordion plugin are incorrect.

Reported by: nmaves Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.accordion Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

The following documentation is not valid.

The markup of your accordion container needs pairs of headers and content panels. By default, the header elements are anchors, assuming the following structure:

<div id="accordion">
    <a href="#">First header</a>
    <div>First content</div>
    <a href="#">Second header</a>
    <div>Second content</div>
</div>

Change History (2)

comment:1 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8

The header element must have display:block, and for icons to work properly, the text must be wrapped in an ancor-element within the header element.

<div id="accordion">
	<h3><a href="#">Accordion Header 1</a></h3>
	<div>
		Accordion Content 1
	</div>
	<h3><a href="#">Accordion Header 2</a></h3>
	<div>
		Accordion Content 2
	</div>
	<h3><a href="#">Accordion Header 3</a></h3>
	<div>
		Accordion Content 3
	</div>
</div>

comment:2 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4468.

Note: See TracTickets for help on using tickets.