Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#4697 closed bug (wontfix)

droppable area shrinks when animated

Reported by: darkhouse Owned by:
Priority: minor Milestone:
Component: ui.droppable Version: 1.7.2
Keywords: droppable, animate, tolerance Cc:
Blocked by: Blocking:

Description

I have setup a system that hides the droppable area until you start dragging something. When you start dragging an item, it opens the droppable area. I have the tolerance set to 'touch'. If I just change the 'left' value of the droppable with css, the draggable drops fine, but when I animate the droppable in, the area in which it registers the 'over' event shrinks, I think to where the content is in the droppable.

In the attached file, you can toggle between lines 127 and 128 to see for yourself. I have an alert setup on the 'over' event. You'll notice you have to drag the draggable in quite far before the alert fires.

At first I thought it was a problem with the 'drop' event on the droppable, as it wasn't working at all. I switched it to use the 'over' and 'out' events to handle a 'dropped' boolean that would be used in the 'stop' event of the draggable to see whether it was dropped properly or not. But that was before I set the droppable tolerance to 'touch'.

I'm marking this with a major priority for 2 reasons. 1) I need this for a client project I'm working on right now, and 2) I can't find a workaround. If I had a workaround, I'd mark it as minor.

Attachments (1)

animate_droppable.html (4.2 KB) - added by darkhouse 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by darkhouse

Attachment: animate_droppable.html added

comment:1 Changed 10 years ago by paul

Resolution: wontfix
Status: newclosed

There are two workarounds:

  • animate the content within the droppable, but not the droppable itself
  • use the refreshPositions option on draggable (carefl - this will completely mess with the performance)

the problem is that the position of the droppable usually gets calculated on drag start, and the position changes through the animation, therefore doesn't match anymore - we can't really fix this.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.