Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4706 closed bug (fixed)

Dialog: can't get value from textarea in modal dialog second time dialog is opened in Opera

Reported by: vrn_shan Owned by:
Priority: critical Milestone: 1.8
Component: ui.dialog Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

See

http://jsbin.com/ufego

Steps to reproduce in Opera:

  1. Click 'click here' link to open the dialog
  2. Type 'some text' in the textarea
  3. Click 'Alert' button to close the dialog
  4. See 'some text' in the alert
  5. Close the dialog
  6. Click 'click here' link to open the dialog
  7. Type 'some more text' in the textarea
  8. Click 'Alert' button to close the dialog

Expected result:

  • See 'some more text' in the alert

Actual result:

  • See no text in the alert

Doesn't happen if you set modal: false, or do in browsers other than Opera.

Change History (5)

comment:1 Changed 10 years ago by Jörn Zaefferer

Refactored testpage: http://jsbin.com/ovovo/edit

comment:2 Changed 10 years ago by Jörn Zaefferer

Another odd behaviour: Don't remove the textarea value on the button-click, then open the dialog, enter something, alert, close, open, remove text manually, alert - that will still alert what you entered previously.

comment:3 Changed 10 years ago by Jörn Zaefferer

Further refactored code: http://jsbin.com/ajasu/edit

comment:4 Changed 10 years ago by Jörn Zaefferer

Neither Scott nor I get anywhere with this. Could you try to produce a testcase with the use of jQuery UI, that we or you could submit to Opera?

comment:5 Changed 10 years ago by Scott González

Resolution: fixed
Status: newclosed

I honestly have no idea what the problem was, but it no longer exists in trunk.

Note: See TracTickets for help on using tickets.