Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#4717 closed bug (notabug)

Datepicker wont display in Firefox

Reported by: seippelk Owned by:
Priority: critical Milestone:
Component: ui.datepicker Version: 1.7.2
Keywords: firefox prototype datepicker Cc:
Blocked by: Blocking:

Description

I am using Firefox version 3.0.1 and I am having a problem using the date picker. My code to make the date picker is

function makeDatePickers() {
    jQuery.noConflict();   

    jQuery(".datePicker").datepicker({
        changeMonth: true, changeYear: true, showOn: 'button', buttonText: 'Click to change the date', buttonImageOnly: true,
        dateFormat: 'mm-dd-yy', buttonImage: "/skins/15584/images/miniCal.gif",
        yearRange:'-100:+100', onClose: function(dateText, inst) {val(this)}
    });
}

The problem is whenever I try and click the button to open it, the calendar never displays. Sometimes, if I click it enough, I can see some of the days at the bottom of the page. I am using prototype on the page so I am wondering if they are conflicting. This works in IE7 however. Thanks for the help.

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: invalid
Status: newclosed

jQuery does not work currently work in hostile environments. If you can track down a specific problem, we may look into it, but just saying that something breaks when something native is changed isn't good enough.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.