Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#4734 closed bug (wontfix)

Select controls are broken on initial tab

Reported by: idlesign Owned by:
Priority: major Milestone: 1.9.0
Component: ui.tabs Version: 1.7.2
Keywords: select Cc:
Blocked by: Blocking:

Description

Even though curious I am, why this bug is not listed yet, but nevertheless: select elements are broken on initially selected tab in IE6 - they all unfold just into 1px height line (see image) giving no chance to select an option.
The same with 1.7.1.

Attachments (1)

ie6selissue.gif (2.5 KB) - added by idlesign 10 years ago.
The issue (with default tabs demo)

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by idlesign

Attachment: ie6selissue.gif added

The issue (with default tabs demo)

comment:1 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8
Priority: criticalmajor

comment:2 Changed 10 years ago by nmuerdter

I'm seeing this same problem of select menus not showing up in IE6 when they're inside tabs. However, I'm actually only seeing this on certain computers, which might explain why this hasn't been more of an issue.

On my own system with IE6 (version 6.0.2900.5512.xpsp_sp3_gdr.090206-1234), I can't replicate this problem at all. However, on two other systems with IE6, this problem happens every time. The only difference I can think of are IE addons installed. The only common addon between the two computers where this problem exists is Adobe's PDF Explorer Bar (I think from Acrobat Professional). I'm not sure if that's the problem, though. Does anyone else have addons installed where this problem exists?

For the time being, I've come up with this ugly hack to switch the tabs on load, to fix this in IE6:

$(document).ready(function() {
  var container = $("#tabs");
  container.tabs();

  // Ugly hack to switch tabs in IE6, fixing select menu bug.
  if($.browser.msie && $.browser.version.substr(0, 1) <= 6) {
    container.tabs("select", 1);
    setTimeout(function() {
      container.tabs("select", 0);
    }, 10);
  }
});

comment:3 Changed 10 years ago by idlesign

Looks like IE6 rendering issue. IE8 proves normal.

comment:4 Changed 10 years ago by queen3

I had the same issue. See my question here: http://stackoverflow.com/questions/2182964/ie6-select-inside-jquery-tabs-does-not-render-dropdown-list. The screenshots look very similar so it's probably the same issue. The bug was caused by

body { font-size: 0.7em; }

in CSS. When I change it to 0.8 or above, the bug is gone.

comment:5 Changed 9 years ago by Scott González

Resolution: wontfix
Status: newclosed

This doesn't sound like something we can fix and it affects a very small percentage of users. If someone finds a reliable fix for this, feel free to re-open this with a patch.

comment:6 Changed 7 years ago by Duncan.Bradley

I found that the work-arounds above worked on some machines with IE6, but not others. There was no reason to it that I could see.

I fixed this issue by hiding all the select comboboxes initally in the style sheet, and then using $('select').show() to re-enable them after the tab build command $( "#tabs" ).tabs().

Last edited 7 years ago by Duncan.Bradley (previous) (diff)

comment:7 Changed 7 years ago by Scott González

@Duncan.Bradley That sounds like browser plugins or something similar.

Note: See TracTickets for help on using tickets.