Opened 10 years ago

Closed 7 years ago

#4735 closed bug (wontfix)

Dialog: Unable To Resize Dialog In IE6

Reported by: jandersen Owned by:
Priority: major Milestone: 1.10.0
Component: ui.dialog Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

I can't resize the modal dialog box in IE6 for the example at http://jqueryui.com/demos/dialog/#modal. In my testing, it seems to be something about having the bgiframe and the modal options both set to true. That's the only way I've been able to reproduce the problem. Confirmed with others that they experience the same issue.

Change History (7)

comment:1 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8
Priority: majorcritical

comment:2 Changed 10 years ago by Jörn Zaefferer

I can shrink it, but not increase its size.

comment:3 Changed 10 years ago by Scott González

Priority: criticalmajor

This works for me. The problem occurs if you move too fast and your cursor leaves the dialog and hovers over the overlay. I'm not sure what's causing that problem.

comment:4 in reply to:  description Changed 10 years ago by watanabe

See: http://blog.oovch.net/article/143202683.html (bgiframe leaves room for improvement.)(by oov, in Japanese)

Abstract: (The misunderstanding is caused by watanabe)

  • bgirame makes an iframe behind the dialog.
  • The iframe is as big as the window.
  • The mouse event to shrink is captured by the dialog.
  • The mouse event to increase is captured by the iframe.
  • workaound: change bgiframe to make a div element over the iframe.

Before:

div class="ui-widget-overlay" ...
 iframe class="bgiframe" tabindex="-1" ... <- original.
div class="ui-dialog" ...

After:

div class="ui-widget-overlay" ...
 div class="bgiframe" ... <- changed.
  iframe tabindex="-1" ... <- as big as parent element.
  div ... <- as big as parent element.
div class="ui-dialog" ...

comment:5 in reply to:  description Changed 10 years ago by watanabe

See: ticket:4903, too.

comment:6 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:7 Changed 7 years ago by petersendidit

Resolution: wontfix
Status: newclosed
Summary: Unable To Resize Dialog In IE6Dialog: Unable To Resize Dialog In IE6

We are dropping support for IE6 in 1.10

Note: See TracTickets for help on using tickets.