Opened 10 years ago

Closed 10 years ago

#4738 closed bug (duplicate)

multi-row tab problem

Reported by: bes_sf Owned by:
Priority: major Milestone: 1.8
Component: ui.tabs Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

My application has a tab pane with many tab pages, so that it is rendered with 2 rows of tabs.

When the first tab (in the first/top row) is the current tab, the second row begins below the second tab (in the top row).

When the second tab is the current tab, then second row begins below the third tab.

When a tab towards the right on the top row is the current tab, the second row begins below the next tab to the right, completing the second row and any remaining tabs are on a new third row.

When the last tab on the top row is the current tab, the remaining tabs are left justified on the second row, as expected.

I discovered this bug using P4A 3.4.0, which is built on jquery ui.

http://sourceforge.net/tracker/?func=detail&aid=2822878&group_id=98294&atid=620566

The problem was confirmed by the P4A developer.

Attachments (1)

tab_pane_problem.png (11.8 KB) - added by bes_sf 10 years ago.
shows the tab problem when different tabs are selected

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by bes_sf

Attachment: tab_pane_problem.png added

shows the tab problem when different tabs are selected

comment:1 Changed 10 years ago by Gravity

I also see this behaviour, attached are images showing how it presents when three columns of tabs are used. Image 1 is when tab 1 is selected, Image 1 Image 2 is when tab 2 is selected. Image 2

comment:2 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8

Need to figure out what the intended behaviour is.

comment:3 Changed 10 years ago by Jörn Zaefferer

Resolution: duplicate
Status: newclosed

Duplicate of #4882

Note: See TracTickets for help on using tickets.