Opened 10 years ago

Closed 9 years ago

#4753 closed bug (duplicate)

ui-helper-hidden-accessible increases page height

Reported by: Mikko Rantanen Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.css-framework Version: 1.7.2
Keywords: datepicker scrollbar Cc:
Blocked by: Blocking:

Description

Currently ui-helper-hidden-accessible positions the datepicker far to the left. If the datepicker is created in such a way that the datepicker node is positioned at the bottom of the page, moving it far left still affects the height of the page - even if the datepicker is later shown in a dialog which floats near the middle.

This causes problems in google-docs like web apps where the page is ideally display-sized and the content is managed with overflow:auto divs. While the overflow:hidden can be set to the page, this only hides the scrollbars in Opera and allows the user to scroll using the mouse wheel or dragging around the edges.

Either adding top:0px to the themeroller ui-helper-hidden-accessible or the fix suggested for ticket #4623 should solve the issue.

Change History (3)

comment:1 Changed 10 years ago by Scott González

Milestone: TBD1.8

comment:2 Changed 10 years ago by Scott González

Component: [meta] ui.themerollerCSS Framework

comment:3 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4623.

Note: See TracTickets for help on using tickets.