Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#4778 closed bug (worksforme)

bug

Reported by: Arz_Zeitgeist Owned by:
Priority: minor Milestone:
Component: ui.draggable Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hi I found a very big bug in jquery ui 1.7.2 please run this code and see what happend:

/ <!doctype html> <html lang="en"> <head>

<title>jQuery UI Draggable - Default functionality</title> <link type="text/css" href="http://jqueryui.com/themes/base/ui.all.css" rel="stylesheet" /> <script type="text/javascript" src="http://jqueryui.com/jquery-1.3.2.js"></script> <script type="text/javascript" src="http://jqueryui.com/ui/ui.core.js"></script> <script type="text/javascript" src="http://jqueryui.com/ui/ui.draggable.js"></script> <link type="text/css" href="../demos.css" rel="stylesheet" /> <style type="text/css"> #draggable { width: 150px; height: 150px; padding: 0.5em; } </style> <script type="text/javascript"> $(function() {

$("#draggable").draggable();

}); </script>

</head> <body> <div class="demo" style="border: 1px solid #090; width: 800px; height: 800px; outline: 1px solid #C30;"> <div id="draggable" class="ui-widget-content">

<p>Drag me around</p>

</div> </div><!-- End demo --> <div class="demo-description"> <p> Enable draggable functionality on any DOM element. Move the draggable object by clicking on it with the mouse and dragging it anywhere within the viewport. </p> </div><!-- End demo-description --> </body> </html> /

when you run code you see than after dragging the box to out of parent box , outline of parent box will drag too.

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: worksforme
Status: newclosed

Can't reproduce.

comment:2 Changed 6 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.